Fichiers SOUND des locomotives

Un matériel pose problème, la communauté peut vous aider
Règles du forum
Si votre problème est résolu merci de bien vouloir éditer votre premier message et d'insérer cette icône de sujet Image

Fichiers SOUND des locomotives

Message non lupar bernard94 » Dim 19 Nov 2017 11:34

Bonjour à toutes et à tous,

J'ai un problème, depuis que j'ai réinstallé tout le matériel, locos et wagons, je m'aperçois que mes locomotives à vapeur n'ont plus de son, seul la 141 C 101 fonctionne.

Quelqu'un pourrait me dire comment faire ou les manips à faire dans les Dossiers Sound pour que les sons fonctionnent sur mes autres machines tel que :
131TB_est
131TB_sncf_13
131TB_sncf_31
131TB_sncf_car
140C_231
140C287
141R568
151A_plm+tender
151A_sncf
151A_sncf_convoi
151A_sncf+tender
220PLM_CoupeVent
231E_CHAPELON
231E_SNCF
231G558
231k8
232_u1
241 C 1 + Tender 30 A 180
241P17101
241P17101_patch
242A1
242AT_plm
242TA

Merci d'avance à tous ceux qui pourront m'aider.
Bon dimanche
Cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar nounours1952 » Dim 19 Nov 2017 12:46

Bonjour à tous,
bernard94 a écrit:je m'aperçois que mes locomotives à vapeur n'ont plus de son

Pour comprendre le problème, il faut ouvrir le fichier .eng de chaque locomotive (la procédure vaut aussi pour les .wag) avec un éditeur de texte.
Dans l'onglet "Edition" tu choisis "Rechercher". Le mot à rechercher est "Sound". Il y a normalement 2 lignes "Sound" par .eng (sauf pour la AI ou X.) : 1 pour les sons extérieurs à l'engin et un autre pour les sons intérieurs.
Tu analyses la ligne "Sound" trouvée et tu vas dans le répertoire "Sound" du matériel. Là, tu regardes si tu as un .sms correspondant (par ex. "Sound ( "D9Eng.sms")). Si ce n'est pas le cas, tu modifies la ligne du fichier .eng avec le .sms trouvé dans le dossier "Sound".

Cette procédure te permets de changer des sons parfois "limite" par des sons plus réalistes.

Dans le répertoire "Trainset", tu peux aussi trouver un "common.snd", voire common.sound (pareil pour les cab.).

Je vais prendre l'exemple des Z2 pour expliquer l'utilité de ces répertoires.
Les Z2 sont nombreuses. Chacune possède un répertoire "Sound" et un autre "Cabview". Tu peux réunir tous les Sound dans un dossier ""common.snd".
Dans ton fichier .eng, tu auras ceci : :
Sound ( "../../common.snd/Z2/Z2eng.sms" )
Sound ( "../../common.snd/Z2/Z2cab.sms" )

Et dans ton Trainset :
Image

On appelle cela un "Alias".

Le sous-répertoire "Z2" contiendra tous les fichiers sons des Z2 (un copier/coller).

Je sais pas si c'est assez clair, sinon redemande. J'essairai de m'appliquer.

Amicalement
nounours1952
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 442
Inscription: Mer 26 Juil 2017 17:36

Re: Fichiers SOUND des locomotives

Message non lupar bernard94 » Dim 19 Nov 2017 16:40

Bonjour,

Merci pour ta réponse.

Mais c'est vachement compliqué, que me conseilles-tu comme éditeur de texte ?

De mon coté je croyais que c'était plus simple que ça, et qu'il suffisait d'aller sur une machine dont le Sound fonctionnait et de faire un copier des fichiers qui s'y trouvaient et de faire un coller dans le Sound de la machine où il n'y avait pas le son.

Quand j'ai eu ta réponse, j'ai fait un test avec le Bloc Note de Windows, mais ça ne marche pas.

Merci pour ta prochaine réponse et excuse moi de te déranger ainsi, mais tu sais quant il s'agit de rentrer dans les fichiers pour y ponctionner des infos et de faire des copier/coller, c'est pas mon fort.

Cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar Tosca » Dim 19 Nov 2017 17:01

Bonjour Bernard,

Pascal a raison dans sa démarche, même si elle peut sembler compliquée, ce qui n'est pas le cas.
Donne moi un exemple de machine où tu veux le son et je te donnerais la manipulation exacte à faire.
Ensuite il te suffira de faire la même chose pour les autres machines, sans passer par un dossier commun.
Amicalement,
Didier ;)
Avatar de l’utilisateur
Tosca
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 77
Inscription: Sam 28 Juil 2012 14:56
Localisation: Ligérien

Re: Fichiers SOUND des locomotives

Message non lupar nounours1952 » Dim 19 Nov 2017 17:02

Re,

t'inquiètes, on a tous commencé comme ça.

bernard94 a écrit:que me conseilles-tu comme éditeur de texte ?
bernard94 a écrit:Bloc Note de Windows

C'est tout bon. Faut juste veiller qu'il ne te change pas l'extension du fichier en .txt, mais qu'il utilise bien l'extension originelle.

bernard94 a écrit:Mais c'est vachement compliqué

Pas plus que ça.
1 - tu ouvres le fichier de ton .eng (on va rester là-dessus pour l'instant)
2 - tu recherches la première ligne "Sound ( ...................)"
3 - tu repères le nom du *.sms. Par ex. : Sound ( "131TBEng.sms" )
4 - tu ouvres le répertoire "Sound" de la machine
5 - tu regardes si ce fichier est présent (normalement, il devrait l'être)
6 - si c'est pas le cas, re-télécharge le matériel. Tu as aussi une banque de sons sur ASW et ils sont de qualité.

Pour te faire la main, je te propose de faire un essai sur un matériel, n'importe lequel. Pique un répertoire "Sound" d'un autre matériel (n'importe lequel) et essaie de modifier les lignes "Sound" de ton matériel en y mettant les .sms du répertoire que tu as piqué. Ne te concentre que sur ça. C'est bien le diable si tu n'y arrives pas.

N'oublie pas de faire une sauvegarde du répertoire de la machine sur laquelle tu fais ces modifications, car c'est juste pour te faire la main.

Autre chose. Tu as sûrement un trainset bien fourni. S'il te manque un .sms, fais une recherche sur l'ensemble de ton trainset. Tu auras peut-être une agréable surprise.

bernard94 a écrit:ça ne marche pas

Il est toujours très utile, quand quelque chose ne fonctionne pas, de préciser ce que l'on fait et ce qui ne fonctionne pas, sinon on risque de répondre à côté.

Amicalement
nounours1952
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 442
Inscription: Mer 26 Juil 2017 17:36

Re: Fichiers SOUND des locomotives

Message non lupar bernard94 » Lun 20 Nov 2017 11:06

Bonjour Didier,

Je vous remercie de vos réponses.

Je commence par toi et je m'excuse pour les autres. Mais j'y reviendrai.

Donc je te donne une de mes locomotives ou j'aimerai y mettre un son.

131TB_est

Merci
Cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar bernard56 » Lun 20 Nov 2017 11:51

Bonjour à tous,
Bonjour Bernard,
Tu veux changer le son de la loco ?
Parce que sinon dans l'archive de la 131TB_est, il y a bien un répertoire Sound !!!
Amicalement.
Bernard
Avatar de l’utilisateur
bernard56
Conducteur
Conducteur
 
Messages: 235
Inscription: Mer 11 Juil 2012 18:41
Localisation: 29170 FOUESNANT

Re: Fichiers SOUND des locomotives

Message non lupar Tosca » Lun 20 Nov 2017 15:14

Bonjour à tous,
bernard56 a écrit:Bonjour à tous,
Bonjour Bernard,
Tu veux changer le son de la loco ?
Parce que sinon dans l'archive de la 131TB_est, il y a bien un répertoire Sound !!!
Amicalement.
Bernard

Bernard je confirme que les éléments "sound" sont déjà inclus dans ce dossier.
Peux-être nous donner un autre exemple...
Amicalement,
Didier ;)
Avatar de l’utilisateur
Tosca
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 77
Inscription: Sam 28 Juil 2012 14:56
Localisation: Ligérien

Re: Fichiers SOUND des locomotives

Message non lupar bernard94 » Lun 20 Nov 2017 16:35

Bonjour à tous,

Oui j'ai bien 3 dossiers dans le Sound de la 131TB_est

131TBcab.sms
131TBeng.sms
131TBwag.sms

Mais cela ne fonctionne pas. Et pour d'autres machines idem.

Cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar bernard56 » Lun 20 Nov 2017 17:06

Bonjour Bernard,

Pourrais-tu lancer OR, et nous dire ce que tu as dans Options et ensuite Audio ?
Amicalement.
Bernard
Avatar de l’utilisateur
bernard56
Conducteur
Conducteur
 
Messages: 235
Inscription: Mer 11 Juil 2012 18:41
Localisation: 29170 FOUESNANT

Re: Fichiers SOUND des locomotives

Message non lupar nounours1952 » Lun 20 Nov 2017 17:42

Re,

bernard56 a écrit:Pourrais-tu lancer OR, et nous dire ce que tu as dans Options et ensuite Audio ?

Bernard, tu peux t'épargner cette démarche.

Il est normal que les sons ne fonctionnent pas, car il manque les fichiers .wav dans le répertoire "Sound". C'est typiquement le genre de matériel que l'on rencontre assez souvent et qui utilise les sons d'un matériel d'origine, en l'occurrence la 380.

Pour vous en convaincre, il suffit d'ouvrir le .sms (du .eng, par ex.) et de faire une recherche avec wav. Ou tout simplement de l'étudier, cela fait aussi partie de l'auto-formation.

Voici ce qu'on y trouve :
Initial_Trigger ( StartLoop ( 1 File ( "../../380/sound/x_a380_power_cruise0.wav" -1 ) SelectionMethod ( SequentialSelection ) ) ).
C'est que l'on appelle aussi un "Alias".

Le répertoire "Sound" complet pesant 26 Mo, je ne sais pas si ja vais pouvoir le joindre à ce fil. Sinon, je le mettrai sur un site de partage. Je vous tiens au courant.

Plus généralement, il existe un logiciel qui s'appelle "Route Riter" et que j'utilise très souvent pour vérifier l'intégrité des routes et du matériel. Ensuite, pour les corrections par lot, j'utilise "TextCrawler" qui permet de faire les corrections dans plusieurs fichiers en une seule opération.

Amicalement

SOUND.zip
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
nounours1952
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 442
Inscription: Mer 26 Juil 2017 17:36

Re: Fichiers SOUND des locomotives

Message non lupar bernard56 » Lun 20 Nov 2017 18:51

Bonsoir Pascal,
Arf ! :oops: possédant la 380, je n'ai pas tilté !!!
Amicalement.
Bernard
Avatar de l’utilisateur
bernard56
Conducteur
Conducteur
 
Messages: 235
Inscription: Mer 11 Juil 2012 18:41
Localisation: 29170 FOUESNANT

Re: Fichiers SOUND des locomotives

Message non lupar Tosca » Lun 20 Nov 2017 19:23

Bonsoir à tous,
bernard56 a écrit:Bonsoir Pascal,
Arf ! :oops: possédant la 380, je n'ai pas tilté !!!
Amicalement.
Bernard

Ah ce Pascal toujours au top... :clap
Amicalement,
Didier ;)
Avatar de l’utilisateur
Tosca
Créateurs-Testeurs
Créateurs-Testeurs
 
Messages: 77
Inscription: Sam 28 Juil 2012 14:56
Localisation: Ligérien

Re: Fichiers SOUND des locomotives

Message non lupar bernard94 » Lun 20 Nov 2017 20:14

Bonsoir à tous,

Qu'appelez-vous la 380 ?

Si c'est le fichier dans le dossier Sound, qui est appelé : a380_power_cruise8, je l'ai mis dans certaines machines.

J'ai essayé de mettre ce fichier dans d'autres fichier Sound et cela ne fonctionne pas.

Dorénavant je ne vais pas insister sur mes problèmes, vous avez été tous très à l'écoute de mes problème depuis le mois de juillet et je vous en remercie, d'une gentillesse extrême pour répondre à toutes mes questions.

Le plus gros problème a été d'avoir TSRE fonctionner, en fait c'est la que j'ai décidé de tout supprimer avec les Brokens que j'avais de tout retélécharger et de réinstaller toutes les machines et wagons, les routes je les avais garder, et je m'aperçois aujourd'hui au cours de faire des convois sur chaque route et au différents départ de ces routes quand je fais des essaies que certaines machines ne font pas de sons. Donc d'après vous, je fais quoi ? je vais chercher une autre machine qui fonctionne correctement.

Je veux plus me prendre la tête à faire des manips dans des dossiers où c'est de la programmation informatique, je n'y connais rien et je ne veux pas connaître, à 64 piges on a envie de se détendre et ne plus à cogiter.

Depuis le mois de juillet je n'ai que télécharger et installer des routes et du matériel, et je n'ai pas encore profiter de rouler sur une route et découvrir la beauté des paysages.

Je sais que je vais pas être déçu pour certaines routes, le début en dit long,

Je vous remercie tous de vos aides, vous faites de très belles choses, vous avez une patience en or pour donner aux autres le plaisir de s'amuser.

Mon frangin m'as posé une question, quand allez-vous faire la route Paris à Vladivostok avec O-E, il Blaguait....

Merci pour tout

Bonne soirée à tous et très bonne continuation à vous tous.
Cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar bernard56 » Lun 20 Nov 2017 21:13

Bonsoir Bernard,
Regardes ta boîte mail, je t'ai envoyé la loco 380.
Installes la.
Cela devrait corriger ton problème.
Amicalement.
Bernard
Avatar de l’utilisateur
bernard56
Conducteur
Conducteur
 
Messages: 235
Inscription: Mer 11 Juil 2012 18:41
Localisation: 29170 FOUESNANT

Re: Fichiers SOUND des locomotives

Message non lupar bernard94 » Mar 21 Nov 2017 13:30

Bonjour Bernard,

Normal aussi que je réponde sur le Forum.

Un miracle s'est produit grâce à l'envoie et de l'installation de la 380 par Bernard, mes locos vapeurs ont retrouvé le son. C'est super.

Merci.
Très cordialement
Bernard
bernard94
Conducteur
Conducteur
 
Messages: 118
Inscription: Jeu 10 Aoû 2017 12:55

Re: Fichiers SOUND des locomotives

Message non lupar bernard56 » Mar 21 Nov 2017 14:26

Bonjour Bernard,
Super ! et bonne continuation pour la suite.
Amicalement.
Bernard
Avatar de l’utilisateur
bernard56
Conducteur
Conducteur
 
Messages: 235
Inscription: Mer 11 Juil 2012 18:41
Localisation: 29170 FOUESNANT


Retourner vers Problèmes liés aux matériels

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités